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Microsoft Excel

• Tabs, Toolbars, Quick Access Toolbar

• Basic Functions & Formulas

• Tips, Tricks, Shortcuts

• Conditional Formatting

• Text to Columns

• VLOOKUP

• Pivot Tables & Charts
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Adding the Developer Tab

• Click on the 

File tab

• Click Options

• Choose 

Customize 

Ribbon

• Check 

Developer box

• Click OK



Developer Tab Items

• The Developer tab is useful for 

advanced features of Excel 2010 such 

as creating and recording Macros, or 

using or editing Visual Basic commands

• It is also necessary if you wish to

insert Form Controls or ActiveX

Controls into your spreadsheet 



Quick Access 

Toolbar
• The Quick Access Toolbar is a 

customizable toolbar that contains a set of 

commands that are independent of the 

tab that is currently displayed. 

• Used to store shortcuts to frequently used 

features 

– Save, Undo/Redo, Spelling, Add Comment 



Adding “$” to a 

Formula

If a dollar sign precedes a row 
number, the row number 

doesn't change when you copy 
it up or down.  
For example:

• =B3 copies up as: =B2

• =B3 copies down as: =B4 

• =B$3 copies up or down as: 
=B$3 

If a dollar sign precedes a 
column letter, the column letter 
doesn't change when you copy 

it right or left.  
For example:

• =B3 copies right as: =C3

• =B3 copies left as =A3

• =$B3 copies right or left as: 
=$B3

If a dollar sign precedes both 
column letters and row 

numbers, the formula copies 
anywhere as a static number.  

For example:

• =$B$3 copies anywhere as: 
=$B$3 

Hint: If you click on the cell address within the formula bar, the F4 key on the keyboard allows 
you to “toggle” through the four possibilities



$ Exercise

• Add a $ to the formulas in Line 9 so that 

you can drag down (or copy) to fill in the 

remaining portion of the table.

• You want to “anchor” the exchange 

rates in Colum D

• Answer: B9=D$3*A9 

$



Sort and Filter

• Found on the HOME page under editing, 

or on the DATA page under sort and 

filter

• Sorting and Filtering allow you to 

manipulate data in a worksheet based on 

given set of criteria



Sort and Filter 

Exercise
• Employee List

• Let’s SORT by First Name then by Hire 

Date

– Highlight all columns of data (otherwise it will 

only sort the columns you highlighted)

– On the Data tab choose SORT

– Sort by First Name (A to Z)

– Add Level and sort by Hire Date (oldest to 

newest)
Sort & Filter



Sort and Filter 

Exercise 
• Now add a FILTER to only show the 

Classified employees who work 4 Hours

– On the DATA Tab choose FILTER

– Column H click on the drop down box and 

select only “Classified”

– Column F click the drop down box and 

select only “4”

Sort & Filter



Conditional Formatting

• Analyzing Data in a Colorful Way 

– On the HOME Tab under Styles

• Formatting that is applied “under some 

condition”. It allows you to format 

certain cells when some type of criteria 

(that you specify) is met. 



Conditional Formatting 

Exercise

• Highlight the movies with a viewer rating 

that is above average (light red fill)

– Highlight column G, select Conditional 

Formatting, Top/Bottom Rules, Above Avg

• Highlight the movies that were released 

prior to 1985 (green fill)

– Highlight column B, select Conditional 

Formatting, highlight cells rules, less than, 

1985, change to green fill Conditional Formatting



Transpose

• When you need to flip-flop data and you 

don't waste time doing it manually.

– Returns a vertical range of cells as a 

horizontal range, or vice versa.

• You can use Transpose as a 

– Paste Option for one-time paste

– Formula for linked cells



Transpose Exercise 1

• Transpose Function
– Highlight the empty cells B2:K2

– Enter =TRANSPOSE(A3:A12) in the formula box

– Then press Ctrl-Shift-Enter to create an array formula

• Paste Special (ONLY want to perform a one-time paste)

– Copy cells A3:A12

– Right click on cell B13, select “Paste Special”

– Select the Transpose checkbox and click 

on the OK button. Transpose 1



Transpose Example 2

• Transpose can also be applied to tables
– Highlight and Copy the entire table (A6:K9)

– Right click where you want to paste the table and 

select “Paste Special” 

– Select the Transpose checkbox and click on the OK 

button.

– You can also use the =TRANSPOSE Formula with 

tables if you want them to be linked
Transpose 2



PROPER

• Proper Function

– One of Excel’s text functions

– Capitalizes the first letter and any other 

letters that follow a non-letter character in a 

text string. Converts all other letters in the 

text string to lowercase letters.

– Useful with employee lists, expenditures 

descriptions, etc



Proper Example 1

• We want to convert the text expenditure 

description in Column A
– Insert a new column between A and B 

– In B2, Enter =PROPER(A2)

– Drag formula down to fill in the remaining cells

– Copy the new data 

– Paste Special and select “Values”

– Delete Column A
Proper 1



Proper Example 2

• Using the PROPER function, convert 

the City Departments 

• Bonus Question: Using a function within 

Excel, remove the duplicate 

departments in the table

Proper 2



Proper Example 2 

Answer
• Proper

– Insert a new column between A and B

– In B4, Enter =PROPER(A4)

– Drag formula down to fill in the remaining cells

– Copy the new data 

– Paste Special and select “Values”

– Delete Column A

• Delete Duplicates

– Make sure cursor is somewhere on the table

– On the Data tab, select “Remove Duplicates” Proper 2



Text to Columns
• Convert Text to Columns: separate 

simple cell content into different 

columns. 

– Depending on the way your data is 

arranged, you can split the cell content: 

• Specific column break location within your data

• A space or a character (comma, a period, or a 

semicolon)



Text to Columns 

Example
• We want to separate the Make and Model 

of the cars (in Column A)
– First you have to insert a column where you want the 

data to go (insert a new column between A and B)

– Highlight the data that you want to split into separate 

columns

– On the DATA tab, select “text to columns” – The 

Convert Text to Column Wizard will appear

– Select “Delimited” and then check “space”

Text to Columns



Tables

• Sometimes it can be tricky when re-

organizing adding or deleting data from 

a table

– Deleting portions of a table

– Insert rows into a table

– Moving tables within a worksheet

Tables



Shortcuts:

Moving and Scrolling 

on Worksheets

• CTRL End: moves to the last cell on a 

worksheet, in the lowest used row of the 

rightmost used column

• CTRL Home: moves to the beginning of 

a worksheet.

• CTRL ↓: moves to the edge of the 

current data region Shortcuts



Shortcuts 

continued
• CTRL Page Down: moves to the next 

sheet in a workbook.

• ALT Page Down: Move one screen to 

the right



More Shortcuts

• Shift + spacebar: select entire row. 

• Ctrl + spacebar: select entire column. 

• Ctrl + Z: undo

• Ctrl C: copy

• Ctrl V: paste

• Ctrl+Shift+$: applies the currency 

format Shortcuts



Data Analysis

• Once installed, this command button will 

appear on the Data Tab in Excel 2007 – 2013 

versions

• If it does not appear, install the Data Analysis 

Toolpak as described in the following steps



Adding the Data 

Analysis ToolPak
• Click on the File 

tab, choose 

Options, and click 

on Add-Ins

• Select Analysis 

ToolPak

• Click on Go

• Click OK to close 

the window



Adding the Data 

Analysis ToolPak
• Once installed, the Data Analysis command appears 

here on the Ribbon under a new Analysis group

• Select the Descriptive Statistics worksheet tab at the 

bottom of the page, and then click on Data Analysis 

to see an example of how this works – columns E 

and F show the results of the Descriptive Statistics of 

the Sample Data in column C

Descriptive Statistics



Using Data Analysis for 

Descriptive Statistics

• To try this yourself, click on the worksheet tab 

named Descriptive Statistics 2, and click on 

cell E1

• On the Data tab, click on Data Analysis

• Select Descriptive Statistics, click OK

• Select the Input Range: C2:C16

• Select cell E1 as your Output Range

• Be sure to check Summary Statistics

• Click OK

Sample Data

17

19

18

17

19

17

18

18

18

18

18

17

17

16

19

Descriptive Statistics 2



• Your data 

should 

appear 

like this:

• But what 

does it 

mean?

Column1

Mean 17.73333

Standard Error 0.228174

Median 18

Mode 18

Standard Deviation 0.883715

Sample Variance 0.780952

Kurtosis -0.48529

Skewness -0.11571

Range 3

Minimum 16

Maximum 19

Sum 266

Count 15

Using Data Analysis for 

Descriptive Statistics

Descriptive Statistics 2



Data Analysis: Descriptive 

Statistics Definitions
Excel Descriptive Statistics Definitions:

Mean: The average of a set of data points

Standard 

Error: The estimate of how well the standard mean approximates the population mean

Median: The number in the middle of a set of numbers

Mode: The most common number in a list of data

Standard 

Deviation: The measure of the average deviation from the mean

Sample 

Variance: The square of the Standard Deviation

Kurtosis:

The sharpness of the peak of data distribution (negative values flatter, positive 

values sharper)

Skewness:

Refers to a lack of symmetry of the curve of data (negative skewness left of center, 

positive skewness right of center)

Range: The difference between the largest and smallest data point values

Minimum: The lowest value in a set of data

Maximum: The highest value in a set of data

Sum: The total of all values in a set of data

Count: The number of values in a set of data



SUBTOTAL

• SUBTOTAL Function

– Returns a subtotal in a list or database

– Unlike SUM, AVERAGE, COUNT etc. 

which do one thing and only one thing, 

SUBTOTAL is versatile. 

– You give SUBTOTAL two things – type of 

subtotal and the range of cells
• =SUBTOTAL (TYPE OF TOTAL, RANGE OF CELLS)



Subtotal

• Type of Subtotal (or Function Number)

– There are 11 types of subtotal, each with a 

designated number 1 -11

• Average (1), Count (2), … Sum (9) and so on

• Range of Cells

– The range that you want to subtotal



SUBTOTAL



SUBTOTAL

• You can use SUBTOTAL to ignore 

values in hidden rows

– Often, we use hide rows to remove 

irrelevant items from view. You can use 

SUBTOTAL so that values in hidden rows 

are neglected.



SUBTOTAL

• SUBTOTAL(9,A1:A10) finds the sum of 

values in cells A1:A10

• SUBTOTAL(109,A1:A10) will find sum 

of values in visible rows only

• See Example (yellow highlighted cells)
• Add a Filter to not show “seasonal” employees

• Notice how the Subtotal changes
Subtotal



SUBTOTAL
• If there are subtotals in SUBTOTAL 

range, they will be neglected



SUBTOTAL 

Example 2

• We can create subtotals in a given list

• Highlight the Table and go to Data Tab

• Click on “Subtotals” - This will launch a Subtotal 

dialog where you can easily specify the type of 

total grouping you want.

• Example:

– Highlight Table (A1:I36)

– On DATA tab select “Subtotal”

– Sum the Number of employees at 

each change in Department Subtotal



VLOOKUP

• VLOOKUP - looks up the value in the first 

column of the range or table and returns 

the corresponding value in a specified 

table or range column. 

• =VLOOKUP (Lookup_value, Table_array, 

Col_ndex_num, Range_lookup



Huh?? 

• In Simpler terms, there is:

– an INPUT (something to search for), 

– a TABLE (to Search in)

– and a RETURNED VALUE (from a specific 

column that you identify)

• Example exercise



VLOOKUP Exercise

• Using the VLOOKUP function, fill in the Fund 

Description (In Column B):

– Lookup_Value: the value to be found in the first column 

of a table

– Table_array: the table in which the data is retrieved

– Col_index_num: The column in the table_array from 

which the matching value is returned

– Range_Lookup: find an exact match, enter “FALSE”

VLOOKUP

=VLOOKUP (A2,'VLOOKUP DATA'!A:B,2, FALSE)



VLOOKUP Exercise

• Using the VLOOKUP function, fill in the 

Department Description

• Department Description (In Column D):

– =VLOOKUP(C2,'VLOOKUP DATA'!D:E,2,FALSE)

VLOOKUP



Pivot Tables

• Great for large lists of data

– expenditures, inventory, staffing lists

• Provides a quick way to extract specific 

information from the data 

– Expenditures by fund, staffing by 

department, vehicle by year, etc



Pivot Tables
• Creating a Pivot Table: 

– Make sure each column of data has a 

heading, or a title. 

– Choose “Pivot Table” on the INSERT Tab

– Highlight the data to be included. You can 

highlight the entire columns

– Option to insert the Pivot Table into a new 

worksheet or existing worksheet





Pivot Tables

• The Pivot Table Field 

List

– Will appear once you 

create your Pivot Table

– Where you manage the 

Pivot Table

– Each “field” represents 

the columns of data 

Report Filter: Area field is 

shown above the Pivot Table. 

Row Labels:  Area field 

shown as Row Labels on the 

Left Side of the Pivot Table

Values: Area field shown as 

summarized numeric values. 

Column Labels: Area field 

shown as column labels at 

the top of the Pivot Table  



Pivot Tables

Pivot Table that illustrates YTD 

Expenses by Department and 

include only the General Fund. 

Fund General 

Row Labels Sum of YTD Expense

Auditor’s Office $444,470

Council $127,437

Law Director $506,898

Mayor’s Office $164,528

Service Director $110,262

Grand Total $1,353,596



Pivot Tables

• Summarize Values 

– Sum, Count, Average …  

• Change how the values are 

summarized within the Value Filed 

Setting

– Click on the Field in the Value Box OR 

Right Click on the Heading in the Actual 

Pivot Table 

Values: Area field shown as 

summarized numeric values. 



Pivot Tables

• Adding filters to Row 

Labels, Column Labels, and 

Values

• Add a Filter to only show 

specific Departments. 



Pivot Table Exercise

• Using the data provided, create a Pivot 

Table illustrating:

– The total (the SUM) of Employees by 

Department

– Include only the following departments: 

• Auditor’s Office, Engineering Office, Health 

Department, Mayor’s Office, Treasurer’s Office, 

and Zoning Department

– Filter the Table to include only employees 

who work 260 days per year.
Pivot 



Pivot Table Exercise: Answer 28.85



Pivot Table Charts

• Simple way to illustrate findings

• Example shows the average hourly rate of 

public works employees at this city

– Pivot Table is already created includes:

• Public Work Departments (filtered)

• Average Rate of Pay (values summarized by avg)

• We can put this data into a chart



Pivot Table Chart

• Make sure your cursor is on the pivot 

table

• Under Pivot Table Tools, select “options”

• Select “PivotChart”

Pivot Chart 



Questions
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